generate-appups giving errors when new application included in new release

Fanjie Wang wangfanjie at gmail.com
Wed Mar 2 19:09:03 EST 2011


the app wasn't part of the previous release.

thanks,
Frank

On Mar 2, 2011, at 4:03 PM, Ken Ellis wrote:

> Actually to clarify, by "new" do you mean the app wasn't part of the previous release, or was it a new version of an existing app.
> 
> On Mar 2, 2011 7:00 PM, "Ken Ellis" <kaellis at gmail.com> wrote:
> > Check that the directory you removed had a .app file for the application.
> > It needs to pull the vsn to determine whether the app needs to be part of
> > the upgrade (the vsn has changed). That's where I usually see this error.
> > On Mar 2, 2011 6:39 PM, "Fanjie Wang" <wangfanjie at gmail.com> wrote:
> >> Hi,
> >>
> >> I'm running into an issue with "./rebar generate-appups" giving out error
> > when the new generated release has a new application.
> >>
> >> The error is:
> >> $ ./rebar generate-appups previous_release=project_3
> >> ==> rel (generate-appups)
> >> ERROR: 'generate-appups' failed while processing /home/user/project/rel:
> > {'EXIT',{{badmatch,none},
> >> [{rebar_appups,'-get_upgraded_apps/2-fun-0-',2},
> >> {lists,map,2},
> >> {rebar_appups,'generate-appups',2},
> >> {rebar_core,run_modules,4},
> >> {rebar_core,execute,4},
> >> {rebar_core,process_dir,4},
> >> {rebar_core,process_each,5},
> >> {rebar_core,process_dir,4}]}}
> >>
> >> If I manually remove the new application from .../project/rel/project/lib
> > folder, then "generate-appups" works.
> >>
> >> Maybe I'm doing something wrong? Thanks for the help in advance!
> >>
> >> Frank
> >>
> >>
> >> _______________________________________________
> >> rebar mailing list
> >> rebar at lists.basho.com
> >> http://lists.basho.com/mailman/listinfo/rebar_lists.basho.com




More information about the rebar mailing list