port_envs vs port_env

Tim Watson watson.timothy at gmail.com
Mon Feb 20 17:45:24 EST 2012


I agree that this is inconsistent and can be confusing. It would be
better IMO to rationalise it now whilst the opportunity is there.

Cheers,

Tim

On 14 February 2012 17:07, Tuncer Ayaz <tuncer.ayaz at gmail.com> wrote:
> As part of further port_compiler work that's underway I've wondered
> if we shouldn't rename port_envs to port_env.
> We've deprecated enough port_compiler options recently, that
> we could comfortably use this opportunity to do the renaming
> as a deprecation (as we did with app= vs apps=).
>
> The new feature in progress which made me realize the naming issue is:
> {port_specs, [{".*", "priv/foo.so", ["src/*.c"],
>               [{env, [port_env(), ...]}]}
>             ]}.
>
> It's a single environment of key/value pair and not multiple environments.
>
> Thoughts?
>
> _______________________________________________
> rebar mailing list
> rebar at lists.basho.com
> http://lists.basho.com/mailman/listinfo/rebar_lists.basho.com



More information about the rebar mailing list