port_envs vs port_env

Tuncer Ayaz tuncer.ayaz at gmail.com
Sat Feb 25 11:52:05 EST 2012


On Mon, Feb 20, 2012 at 11:45 PM, Tim Watson wrote:
> I agree that this is inconsistent and can be confusing. It would be
> better IMO to rationalise it now whilst the opportunity is there.

Thanks, we've decided to deprecate port_envs in favor of port_env.

> On 14 February 2012 17:07, Tuncer Ayaz wrote:
>> As part of further port_compiler work that's underway I've wondered
>> if we shouldn't rename port_envs to port_env.
>> We've deprecated enough port_compiler options recently, that
>> we could comfortably use this opportunity to do the renaming
>> as a deprecation (as we did with app= vs apps=).
>>
>> The new feature in progress which made me realize the naming issue is:
>> {port_specs, [{".*", "priv/foo.so", ["src/*.c"],
>>               [{env, [port_env(), ...]}]}
>>             ]}.
>>
>> It's a single environment of key/value pair and not multiple environments.
>>
>> Thoughts?



More information about the rebar mailing list