delete doe not work

Todd Lumley todd at thesolutionstudio.com
Wed Dec 9 20:31:29 EST 2009


I'm also curious if anyone has had success in Deleting bucket key's via
JIAK.  no luck here.
is there a fix?

todd
 delete doe not work
christian krupa ich at christian-krupa.de
Sat Oct 31 10:25:56 EDT 2009

  a.. Previous message: Bucket Parameters in the Ring
  b.. Next message: full-writes vs. merges
  c.. Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

----------------------------------------------------------------------------
----

hi there,

just tested the riak php demo and wonder why the demo set ist was not
deleted at the end of the demo. even an expicit delete call to the id
does not work. i tested the delete over a periode of 5minutes so it
should not be a delete lag.
some system info: riak 0.6 on a single macbook pro with erlang port.
any thoughts?


here is some debug code:
string(59) "GET: http://127.0.0.1:8098/jiak/jiak_example/leaf352234?r=2"
string(0) ""
object(JiakObject)#2 (7) {
   ["bucket"]=>
   string(12) "jiak_example"
   ["key"]=>
   string(10) "leaf352234"
   ["links"]=>
   array(0) {
   }
   ["object"]=>
   array(1) {
     ["foo"]=>
     string(20) "good news & a snack!"
   }
   ["vtag"]=>
   string(22) "7NEWFWxUr1eURN1ZGkA3dM"
   ["lastmod"]=>
   string(29) "Sat, 31 Oct 2009 13:50:46 GMT"
   ["vclock"]=>
   string(44) "a85hYGBgzGDKBVIs7KdXCGQwJTLmsTJs25NwhC8LAA=="
}
string(63) "DELETE: http://127.0.0.1:8098/jiak/jiak_example/leaf352234&dw=2
"
string(0) ""
array(2) {
   ["resp"]=>
   string(193) "<HTML><HEAD><TITLE>404 Not Found</TITLE></
HEAD><BODY><H1>Not Found</H1>The requested document was not found on
this server.<P><HR><ADDRESS>mochiweb+webmachine web server</ADDRESS></
BODY></HTML>"
   ["http_code"]=>
   int(404)
}


cya
christian

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20091209/c25fe9af/attachment-0002.html>


More information about the riak-users mailing list