jiak 500 errors

Alex Laslavic alex.laslavic at turner.com
Mon Dec 14 17:38:17 EST 2009


On Mon, 2009-12-14 at 12:07 -0500, Bryan Fink wrote:
> On Mon, Dec 14, 2009 at 11:42 AM, Alex Laslavic
> <alex.laslavic at turner.com> wrote:
> > On Mon, 2009-12-14 at 08:25 -0800, Dan Reverri wrote:
> >> On Mon, Dec 14, 2009 at 7:43 AM, Alex Laslavic
> >> <alex.laslavic at turner.com> wrote:
> >>         Got a bit of an issue.  Through jiak, I am able to store a
> >>         handful of
> >>         values, and then it starts returning 500 errors.  Once it
> >>         starts
> >>         returning 500's, I can't get it to store any more docs
> unless
> >>         I wipe the
> >>         storage and ring directories.  I am still able to retrieve
> >>         values.  I am
> >>         still able to store new values via the erl client.  Not
> seeing
> >>         anything
> >>         of interest when attaching the logger event handler.
> >>
> >>         Any ideas.
> >>
> >>         --
> >>         Alex Laslavic
> >>
> >>         _______________________________________________
> >>         riak-users mailing list
> >>         riak-users at lists.basho.com
> >>
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >>
> >>
> >>
> >> What version of Riak are you running?
> > I'm running the tip from 2009/12/08.
> >
> >> Are you declaring a schema for the bucket?
> > I am leaving the schema at its defaults.
> >
> >> Can you try running Riak in debug mode (debug-fresh.sh) and
> reproduce
> >>  the issue?
> >
> > =ERROR REPORT==== 14-Dec-2009::11:46:14 ===
> > webmachine error: path="/jiak/group/tegpool-cache-dev/"
> > {error,function_clause,
> >       [{lists,foldl,
> >               [#Fun<sets.1.88325074>,
> >                {set,0,16,16,8,80,48,
> >
> {[],[],[],[],[],[],[],[],[],[],[],[],[],[],[],[]},
> >
> > {{[],[],[],[],[],[],[],[],[],[],[],[],[],[],[],[]}}},
> >                null]},
> >        {jiak_resource,copy_unreadable_props,3},
> >        {jiak_resource,diff_objects,2},
> >        {jiak_resource,object_forbidden,2},
> >        {webmachine_resource,resource_call,3},
> >        {webmachine_resource,do,3},
> >        {webmachine_decision_core,resource_call,1},
> >        {webmachine_decision_core,decision,1}]}
> 
> Hi, Alex.  Could you please send me two more things:
> 
> 1. The schema, as returned by Jiak, for the "group" bucket
Just using the default schema.

{"schema":{"allowed_fields":"*","required_fields":[],"read_mask":null,"write_mask":null}}
> 
> $ curl http://localhost:8098/jiak/group?keys=false
> 
> 2. An example object that you've stored in that bucket.
Here is one that I can't get to store.

{"bucket":"group","links":[],"object":{"parameters":"hi","classes":["class1"]},"key":"group1"}

and debug is currently reporting

{error,badarg,
       [{lists,member,[<<"parameters">>,null]},
        {jiak_resource,'-check_write_mask/2-lc$^0/1-0-',2},
        {jiak_resource,check_write_mask,2},
        {jiak_resource,object_forbidden,2},
        {webmachine_resource,resource_call,3},
        {webmachine_resource,do,3},
        {webmachine_decision_core,resource_call,1},
        {webmachine_decision_core,decision,1}]}






Does that help?
> 
> Thanks,
> Bryan
> 
> 
-- 
Alex Laslavic




More information about the riak-users mailing list