riak won't start

David Smith dizzyd at basho.com
Mon Dec 21 09:59:47 EST 2009


On Mon, Dec 21, 2009 at 7:54 AM, francisco treacy
<francisco.treacy at gmail.com> wrote:
> Wow, Erlang can be quite unwieldy :)  My weapon is however always
> handy: `killall beam beam.smp heart erl`.

Just don't do that on a Solaris box... :)

> I issued the Riakka (scala-riak) test suite, and it was not slow, it
> was unbelievably slow until it spits out the same thing as a normal
> GET through curl [1] - I tried to understand the trace but no dice...
>
> What I also tried is commenting out the 'domain' in /etc/resolv.conf.
> And roll back to the previous state without inetrc. It starts ok but
> the test fails.

My guess here is that Riakka and the test are failing/slow because you
previously got it started with a unresolvable DNS name which is now
cached in your ring state. Stop the server and delete everything in
data/ring/* When you restart the server, it should work properly.

I typically hang out in #riak on freenode -- if you have questions
feel free to drop by. :)

D.




More information about the riak-users mailing list