problem building and/or starting riak

David Smith dizzyd at basho.com
Wed Dec 23 07:30:33 EST 2009


If you want to make it work with 5.7.5, for the moment, you must
simply rename the directory rel/overlay/erts-5.7.4 to
rel/overlay/erts-5.7.5 and then clean everything and rebuild.

In general it's better to use the last released version of erlang than
the head of git repo unless you absolutely need some new feature.
There are typically 4-5 releases of the erlang system a year, so
running most recent release is never very old.

At some point I do need to fix the erts-VSN directory problem. :)

D.

On Tue, Dec 22, 2009 at 11:03 PM, Chris Duesing <chris.duesing at gmail.com> wrote:
> I wanted to upgrade to the latest riak, but my Erlang version was too old. I
> went to github and upgraded to the latest (erts 5.7.5) I then ran 'make all
> rel' from the top riak directory and everything seemed to go fine. I then
> ran rel/riak/bin/riak start and got the following error:
>
> escript: Failed to open file:
> /home/chris/Erlang/riak/rel/riak/erts-5.7.5/bin/nodetool
>
> I poked around and noticed there is an erts-5.7.4 directory at the same
> level as the 5.7.5 that has nodetool. I tried copying it over but when I ran
> start things really blew up.
>
> Is there a compatibility issue with 5.7.5?
>
> Chris
>
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>




More information about the riak-users mailing list