riak 0.7 build fails on ubuntu

Kevin A. Smith kevin at hypotheticalabs.com
Mon Dec 28 18:24:18 EST 2009


On Dec 28, 2009, at 4:00 PM, Andrei Dziahel wrote:

> Hi all.
> 
> Ok, how to reproduce %subj%.
> First you need an ubuntu box (9.10, in my case).
> Second - Erlang r13b3 (can be taken in this PPA)
> Third - riak sources
> 
> Let's follow the manual:
> $ make all rel
> ./rebar compile
> ==> mochiweb (compile)
> ==> webmachine (compile)
> ==> riak (compile)
> ./rebar compile generate 
> ==> mochiweb (compile)
> ==> webmachine (compile)
> ==> riak (compile)
> ==> rel (generate)
> ERROR: Unable to generate spec: read file info /usr/lib/erlang/man/man5/modprobe.d.5 failed
> 
> make: *** [rel] Error 1
> 
> I'm pretty newbie in erlang and in OTP, so I almost can't get what I'm doing wrong.
> 
> Any ideas?
> 
> Thanks in advance.
> -- 
> With the best regards, Andrei.
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

You might want to consider building Erlang from scratch instead of using the Ubuntu package. This is not the first time I've seen problems with the way Ubuntu and Debian package Erlang. Building Erlang isn't as daunting as it sounds and you wind up with a Erlang installation which will work 99.999% of the time.

--Kevin



More information about the riak-users mailing list