nodes aren't talking

B. Todd Burruss bburruss at real.com
Thu Nov 5 12:09:08 EST 2009


i've setup two riak nodes on separate machines and they don't seem to be
talking.  i've even used wireshark to monitor the activity.  i see the
servers listening on their web ports, but nothing on the doorbell port.
i've tried with version 0.6 and also version 379 from version control

i'm using the java_client like this:


JiakObject	obj = new JiakObject( "mybucket", key );
obj.set( "anything", value );

JiakClient	riakClient = new JiakClient( "riak-btb1", "8001" );
riakClient.setBucketSchema( "mybucket", Arrays.asList(new
String[]{"anything"}), null, null, null );
riakClient.store( obj, 2, 2 );


i start the first server like this:

./start-fresh.sh config/btoddb.erlenv

and i start the second server like this:

./start-join.sh config/btoddb.erlenv riak-btb1 9000

here is my riak config (i modify the host names and node name for the
second node):

{cluster_name, "btoddb-cluster"}.
{ring_state_dir, "btoddb/ringstate"}.
{ring_creation_size, 16}.
{gossip_interval, 10000}.
{doorbell_port, 9000}.
{storage_backend, riak_dets_backend}.
{riak_dets_backend_root, "btoddb/dets-store"}.
{riak_cookie, default_riak_cookie}.
%% {riak_heart_command, "(cd /btoddb/riak-0.6; ./start-restart.sh
config/btoddb.erlenv)"}.
{riak_nodename, btb1}.
{riak_hostname, "riak-btb1"}.

{jiak_name, "jiak"}.
{riak_web_ip, "riak-btb1"}.
{riak_web_port, 8001}.
{riak_web_logdir, "btoddb/weblogs"}.

when i run the servers and use the java client, data is only saved on
the server that the client connected to.   if i stop the client and
point it to the second server, it will only write to the second server.
i see no evidence that the servers are even trying to communicated.  i
have used wireshark to verify this.  these are linux boxes without any
firewalls running.  i have tried it on ubuntu and centos.

any ideas?  thx!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20091105/de9c88fc/attachment-0002.html>


More information about the riak-users mailing list