Ubuntu 9.10 compilation error

Amos Shapira amos.shapira at gmail.com
Sun Nov 29 16:06:30 EST 2009


Hello,

I tried to "hg clone" riak on a Ubuntu 9.10 (32 bit) and get errors like:


make[1]: Entering directory `/home/amos/src/riak/deps/webmachine'
make[2]: Entering directory `/home/amos/src/riak/deps/webmachine/deps/mochiweb'
(cd src;make all)
make[3]: Entering directory
`/home/amos/src/riak/deps/webmachine/deps/mochiweb/src'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory
`/home/amos/src/riak/deps/webmachine/deps/mochiweb/src'
make[2]: Leaving directory `/home/amos/src/riak/deps/webmachine/deps/mochiweb'
{"init terminating in
do_boot",{undef,[{make,all,[]},{erl_eval,do_apply,5},{erl_eval,expr,5},{init,start_it,1},{init,start_em,1}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()
make[1]: *** [erl] Error 1
make[1]: Leaving directory `/home/amos/src/riak/deps/webmachine'
make: *** [webmachine] Error 2

I've never used Mercurial before but tried also:

hg up -r riak-0.6.2
1 files updated, 0 files merged, 0 files removed, 0 files unresolved

But get same error. I also tried to go back down to 0.6 but still same error.

Is there a recommended version to try out Riak?

Also, a litle separately, is there a known good Erlang RPM for CentOS?

Thanks,

--Amos




More information about the riak-users mailing list