Ubuntu 9.10 compilation error

Hisham Ismail mhishami at gmail.com
Sun Nov 29 23:46:29 EST 2009


Make sure you run:

sudo apt-get build-dep erlang

And then do make clean; make again


On Mon, Nov 30, 2009 at 5:06 AM, Amos Shapira <amos.shapira at gmail.com>wrote:

> Hello,
>
> I tried to "hg clone" riak on a Ubuntu 9.10 (32 bit) and get errors like:
>
>
> make[1]: Entering directory `/home/amos/src/riak/deps/webmachine'
> make[2]: Entering directory
> `/home/amos/src/riak/deps/webmachine/deps/mochiweb'
> (cd src;make all)
> make[3]: Entering directory
> `/home/amos/src/riak/deps/webmachine/deps/mochiweb/src'
> make[3]: Nothing to be done for `all'.
> make[3]: Leaving directory
> `/home/amos/src/riak/deps/webmachine/deps/mochiweb/src'
> make[2]: Leaving directory
> `/home/amos/src/riak/deps/webmachine/deps/mochiweb'
> {"init terminating in
>
> do_boot",{undef,[{make,all,[]},{erl_eval,do_apply,5},{erl_eval,expr,5},{init,start_it,1},{init,start_em,1}]}}
>
> Crash dump was written to: erl_crash.dump
> init terminating in do_boot ()
> make[1]: *** [erl] Error 1
> make[1]: Leaving directory `/home/amos/src/riak/deps/webmachine'
> make: *** [webmachine] Error 2
>
> I've never used Mercurial before but tried also:
>
> hg up -r riak-0.6.2
> 1 files updated, 0 files merged, 0 files removed, 0 files unresolved
>
> But get same error. I also tried to go back down to 0.6 but still same
> error.
>
> Is there a recommended version to try out Riak?
>
> Also, a litle separately, is there a known good Erlang RPM for CentOS?
>
> Thanks,
>
> --Amos
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20091130/c23730aa/attachment-0002.html>


More information about the riak-users mailing list