could_not_reach_node on Mac OS X 10.5

Dan Reverri reverri at gmail.com
Thu Oct 8 11:51:14 EDT 2009


When riak is started the shell script using erl to dynamically
determine hostname, node name, and cookie. The hello there string is
appearing in all these parameters.

You might want to check if a boot file is in your install of Erlang:
Specifies the name of the boot script, File.boot, which is used to
start the system. See init(3). Unless File contains an absolute path,
the system searches for File.boot in the current and
<ERL_INSTALL_DIR>/bin directories .
If this flag is omitted, the <ERL_INSTALL_DIR>/bin/start.boot boot
script is used.

On Thursday, October 8, 2009, Dan Reverri <reverri at gmail.com> wrote:
> Hi Brian
>
> You can try using debug-fresh.sh to start your riak node. This might
> show you the problem or point you in the right direction. Make sure
> you stop any currenty running nodes before starting  a new one.
>
>
> On Thursday, October 8, 2009, Brian Hammond <brian at brianhammond.com> wrote:
>> Hello,
>> I'm having some problems getting Riak to work on Mac OS X.
>> I built erlang from otp_src_R13B02-1.tar.gz using just ./configure; make; sudo make install.
>> $ erl --versionErlang R13B02 (erts-5.7.3) [source] [smp:2:2] [rq:2] [async-threads:0] [kernel-poll:false]
>> hello thereEshell V5.7.3  (abort with ^G)1>
>>
>> (side note: whenever erl is invoked, "hello there" is printed; strange).
>>
>> I checked out Riak from the hg repository and ran make.
>>
>> I updated config/riak-demo.erlenv to point to the correct directory.  For me, that's /Users/brian/OpenSource/database/riak
>> {cluster_name, "default"}.{ring_state_dir, "priv/ringstate"}.%% note: make sure you configure your operating system limits for maximum%% open files (using ulimit/sysctl) when creating larger ring sizes. {ring_creation_size, 16}.{gossip_interval, 60000}.{doorbell_port, 9000}.{storage_backend, riak_ets_backend}.%{riak_dets_backend_root, "priv/store/dets"}.{riak_cookie, riak_demo_cookie}.{riak_heart_command, "(cd /Users/brian/OpenSource/database/riak; ./start-restart.sh /Users/brian/OpenSource/database/riak/config/riak-demo.erlenv)"}.{riak_nodename, riakdemo}.{riak_hostname, "127.0.0.1"}.{riak_web_ip, "127.0.0.1"}.{riak_web_port, 8098}.{jiak_name, "jiak"}.
>> Next I ran ./start-fresh config/riak-demo.erlenv and verified that it was running (ps).
>> 18691   ??  S      0:00.42 /usr/local/lib/erlang/erts-5.7.3/bin/beam.smp -K true -- -root /usr/local/lib/erlang -progname erl -- -home /Users/brian -heart -noshell -noinput -connect_all false -pa deps/webmachine/ebin -pa ebin -name hello there riakdemo at hello there 127.0.0.1 -setcookie hello there riak_demo_cookie -run riak start config/riak-demo.erlenv
>> Next step:
>>  ./riak_demo.escript config/riak-demo.erlenv hello thereAttempting to connect to 'riakdemo at 127.0.0.1 <javascript:_e({}, 'cvml', '\x26#39;riakdemo at 127.0.0.1');>' with cookie riak_demo_cookie...Error: failed to connect to Riak cluster: {error,                                           {could_not_reach_node,                                            'riakdemo at 127.0.0.1 <javascript:_e({}, 'cvml', '\x26#39;riakdemo at 127.0.0.1');>'}}
>> I also tried using curl:
>> curl -v -X PUT 127.0.0.1:8098/jiak/artist -H "Content-type: application/json" -d '{"schema": {"allowed_fields": ["albums", "members"], "write_mask": ["albums", "members"], "required_fields": [], "read_mask": ["albums", "members"]}}'
>> but this failed with the same reason:
>> * About to connect() to 127.0.0.1 port 8098 (#0)*   Trying 127.0.0.1... connected* Connected to 127.0.0.1 (127.0.0.1) port 8098 (#0)> PUT /jiak/artist HTTP/1.1> User-Agent: curl/7.16.3 (powerpc-apple-darwin9.0) libcurl/7.16.3 OpenSSL/0.9.7l zlib/1.2.3> Host: 127.0.0.1:8098> Accept: */*> Content-type: application/json> Content-Length: 149> * Empty reply from server* Connection #0 to host 127.0.0.1 left intactcurl: (52) Empty reply from server* Closing connection #0
>>
>> Riak seems to be accepting connections however:
>> $ telnet 127.0.0.1 8098Trying 127.0.0.1...Connected to localhost.Escape character is '^]'.
>>
>>
>> Does anyone know what's going on here?
>>
>> Thanks,Brian
>>
>>
>>
>>
>




More information about the riak-users mailing list