problem with Riak search while searching with ruby client.

Krishna Krishnamaneni kkrishnamaneni at attinteractive.com
Wed Dec 29 20:04:55 EST 2010


Hi, 
  I am using Riak search and I am trying to run a search using ruby client but i get back an error : 

 >>  c.search("tipdt", "t:restaurant")
Riak::FailedRequest: Expected 200 from Riak but received 500. <html><head><title>500 Internal Server Error</title></head><body><h1>Internal Server Error</h1>The server encountered an error while processing this request:<br><pre>{error,{throw,{unhandled_type,date},
              [{riak_solr_output,convert_type,2},
               {riak_indexed_doc,'-to_mochijson2/2-lc$^0/1-0-',2},
               {riak_indexed_doc,'-to_mochijson2/2-lc$^0/1-0-',2},
               {riak_indexed_doc,to_mochijson2,2},
               {riak_solr_output,'-json_response/7-lc$^0/1-0-',2},
               {riak_solr_output,json_response,7},
               {riak_solr_searcher_wm,to_json,2},
               {webmachine_resource,resource_call,3}]}}</pre><P><HR><ADDRESS>mochiweb+webmachine web server</ADDRESS></body></html>
	from /Library/Ruby/Gems/1.8/gems/riak-client-0.8.2/lib/riak/client/curb_backend.rb:70:in `perform'
	from /Library/Ruby/Gems/1.8/gems/riak-client-0.8.2/lib/riak/client/http_backend.rb:72:in `get'
	from /Library/Ruby/Gems/1.8/gems/riak-client-0.8.2/lib/riak/search.rb:53:in `search'
	from (irb):3

 Did anyone see this before, when i run a query through http it works with xml response, but if i ask for json format it gives me the same error as above, I have 4 fields in the document, 2 of them are string type and 1 of them is date type and the other one if of number type. any thoughts?

Thanks in advance, 
Krishna.





More information about the riak-users mailing list