0.8 Fails to start but builds with no apparent errors

Jason Tanner jt4websites at googlemail.com
Wed Feb 3 20:53:49 EST 2010


Hi,

Thanks for the info, it helped me make progress :)

Doing the following:

chcon -t texrel_shlib_t rel/riak/lib/erlang_js-0.1/priv/spidermonkey_drv.so
chcon -t texrel_shlib_t apps/erlang_js/priv/spidermonkey_drv.so

Allowed me to get riak to start with selinux enabled.

However, I now get the following:

Exec: /home/riak/riak/rel/riak/erts-5.7.4/bin/erlexec -boot
/home/riak/riak/rel/riak/releases/0.8/riak -embedded -config
/home/riak/riak/rel/riak/etc/app.config -args_file
/home/riak/riak/rel/riak/etc/vm.args -- console
Root: /home/riak/riak/rel/riak
Erlang R13B03 (erts-5.7.4) [source] [smp:2:2] [rq:2] [async-threads:5]
[hipe] [kernel-poll:true]

** Bad path can't read
/home/riak/riak/rel/riak/lib/kernel-2.13.4.ez/kernel-2.13.4/ebin
** Bad path can't read
/home/riak/riak/rel/riak/lib/stdlib-1.16.4.ez/stdlib-1.16.4/ebin
..
..
..
.. -snip-
..
** Found 0 name clashes in code paths

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.89.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.91.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.92.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.93.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.94.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.95.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.96.0>)

=INFO REPORT==== 4-Feb-2010::01:35:37 ===
Spidermonkey VM host starting (<0.97.0>)
Eshell V5.7.4  (abort with ^G)
(riak at 127.0.0.1)1> q().

As you can see the console starts, but those bad-path errors have me
stumped.

My erlang knowledge is not that great, so perhaps its something simple.

Taking the first reported bad path,

this part: /home/riak/riak/rel/riak/lib/kernel-2.13.4.ez exists as a file,
its not a directory.

So, for me, the error, is valid,
since /home/riak/riak/rel/riak/lib/kernel-2.13.4.ez/kernel-2.13.4/ebin can't
exist.


Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100204/7648b71b/attachment.html>


More information about the riak-users mailing list