Not much luck with Riak 0.7.1 on CentOS 5.4

Mårten Gustafson marten.gustafson at gmail.com
Thu Feb 4 03:44:08 EST 2010


On Wed, Feb 3, 2010 at 4:08 PM, Andy Gross <andy at basho.com> wrote:
> Hi Mårten,
> I missed a step in my instructions below.  Here's the proper order of
> operations:
> % rm -Rf rel/riak
> % make clean all
> % make rel
> % cd rel/riak
> % bin/riak console (or bin/riak start to launch in the background - you can
> run bin/riak attach later to get an Erlang console)
> Sorry 'bout that.

Thanks Andy!

I did the above and also ran riak-admin test which completed
successfully. I then moved the rel/riak directory to its proper
location which also included using my own app.config. This caused the
same crash behaviour as yesterday. Thus I started to suspect my
configuration.

Since the crash reports "dets:open_file failed" the only configuration
key I could think of was ring_creation_size. So I changed this back to
the default of 64 instead of 1024 that I'd bumped it to. This seems to
have solved the problems. I've runs some initial test putting keys on
node X and retrieving from node Y and Z.

1) Any thoughts on why the ring_size would cause the crash - some
system resource I ought to check?
2) On a side note. When I run riak stop I always get left with a epmd
process is that intended?



/mårten.




More information about the riak-users mailing list