Dependency on erts 5.7.4

Steve Davis steven.charles.davis at gmail.com
Mon Feb 22 20:14:30 EST 2010


Hi Tuncer,

Thanks for the reply.

I was intending to run riak on a system that is currently tied to R12. 
Looking through the code I couldn't really see any reason, apart from 
the use of rebar for the build, why 13B is required for riak. I'll be 
honest and say that at closer inspection, the limited use of protobuffs 
(one message) didn't seem to justify the dependency on some third party 
standard (i.e. google's). Long and short, I simply didn't bother this 
time around. I see the removal of Jiak as a positive move toward wider 
acceptance. Perhaps the above experience of mine will at least inform 
some further improvements in bringing riak to the rest of us.

/s


Tuncer Ayaz wrote:
> On Sun, Feb 21, 2010 at 7:54 PM, Steve Davis
> <steven.charles.davis at gmail.com> wrote:
>> Hi,
>>
>> Is there any reason to require R13B other than for the "rebar" build
>> tool?
>>
>> I have some ubuntu servers running and try to use apt exclusively
>> when administering them -- and the apt package is only up to R12B...
>>
>> Rebar complains at me that I need 5.7.4 to compile Riak + deps.
> 
> Rebar relies on reltool and riak relies on both for building
> a rel(ease). The built release will have an embedded erts and
> does not use any system-wide erts at all when you run riak.
> 
> So you can just copy a riak release over to a system with
> or without any Erlang version.
> 
> You only need to make sure that the erts used when building
> a riak release will run on the target distro/server.
> 
> Does this help?
> 





More information about the riak-users mailing list