Trouble binding to public IP

David Smith dizzyd at basho.com
Mon Jan 11 21:20:06 EST 2010


Make sure the riak_web_ip setting is set to 0.0.0.0 as well.

D.

On Mon, Jan 11, 2010 at 7:11 PM, Ken Sedgwick <ksedgwic at bonsai.com> wrote:

> Greetings,
>
> I'm attempting to run riak in a cluster of EC2 nodes.
>
> I've modified my vm.args file as follows:
>
> --- ./etc/vm.args.ORIG  2010-01-03 01:09:38.000000000 +0000
> +++ ./etc/vm.args       2010-01-12 01:23:31.000000000 +0000
> @@ -1,6 +1,6 @@
>
>  ## Name of the riak node
> --name riak at 127.0.0.1
> +-name riak
>
>  ## Cookie for distributed erlang
>  -setcookie riak
>
> This doesn't seem to do it; netstat -nap still only shows the
> 127.0.0.1:8098 port bound.
>
> I also tried w/
> ip-10-160-182-63.us-west-1.compute.internal
> and
> 10.160.182.63
> but no love either.
>
> Any clues to what I might be doing wrong?
>
> Many thanks in advance!
>
> Ken
>
> --
> Ken Sedgwick
> Bonsai Software, Inc.
> http://www.bonsai.com/ken/
> (510) 610-4162
> ken+5a4 at bonsai.com <ken%2B5a4 at bonsai.com>
> Public Key: http://www.bonsai.com/ken/ken.asc
> GPG Fingerprint: 851E 3B07 E586 0843 9434  5CC7 4033 3B9B 3F3F 9640
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100111/5a024fda/attachment.html>


More information about the riak-users mailing list