Newbie: Compile Error

Bryan Fink bryan at basho.com
Wed Jan 13 16:16:03 EST 2010


On Tue, Jan 12, 2010 at 6:24 AM, Madireddy Samuel Vijaykumar
<mad.vijay at gmail.com> wrote:
> I am new to erlang/riak. Its that such tool exists. For application that
> runs behind loadbalacer its becomes very easy for us to store sessions if
> this work. But it hit this...
>
> :~/riak# export LD_LIBRARY_PATH=/mnt/ephemeral/lib:$LD_LIBRARY_PATH
> :~/riak# make all rel
> ./rebar compile
> make: *** [compile] Error 1
>
> while installing riak. I have Erlang R13B03 but without "fop". Is there
> something that i am missing?

Hi.  Could you please check a couple of things:

1. What's the output of 'hg head'?

2. What's the output of './rebar compile verbose=1'?

Another user had a similar problem a few weeks ago.  The thread
discussing that issues is here:

http://lists.basho.com/pipermail/riak-users_lists.basho.com/2009-December/000275.html

The issue there ended up being the libssl-dev was not installed, so
the 'crypto' Erlang app hadn't been built.  So, it's probably also
worth checking that, and installing it, then recompiling Erlang, if
necessary.

-Bryan




More information about the riak-users mailing list