Newbie: Compile Error

Madireddy Samuel Vijaykumar mad.vijay at gmail.com
Tue Jan 19 04:36:33 EST 2010


On Tue, Jan 19, 2010 at 12:19 AM, Bryan Fink <bryan at basho.com> wrote:

> On Mon, Jan 18, 2010 at 7:29 AM, Madireddy Samuel Vijaykumar
> <mad.vijay at gmail.com> wrote:
> > Yeah! you were right about the ssl depenedencies not satisfied. Now i
> have
> > made a partially sucessful installation. Thoough when is run the admin
> test
> > i get the following.
> >
> > riak2:~/riak/rel/riak# ./bin/riak-admin test
> > {error_logger,{{2010,1,18},{
> > 11,40,9}},"Can't set long node name!\nPlease check your
> configuration\n",[]}
>
> This is likely a DNS configuration issue.  Could you please try
> editing bin/riak-admin?  Near the bottom you'll find the line:
>
> $ERTS_PATH/erl -noshell -name riak_test $COOKIE_ARG \
>               -eval "riak:client_test(\"$NODE_NAME\")" -s init stop
>
> Change that to read:
>
> $ERTS_PATH/erl -noshell -name riak_test at 127.0.0.1 $COOKIE_ARG \
>               -eval "riak:client_test(\"$NODE_NAME\")" -s init stop
>
> That is, change the -name argument from just "riak_test" to
> "riak_test at 127.0.0.1".
>
> If this fix works for the "riak-admin test" command, it will also work
> for the other riak-admin commands.  If you can confirm that this was
> the cause of the error, we'll work on patching bin/riak-admin to
> handle DNS configuration oddities better.
>
> -Bryan
>
Thanks Bryan,

Yes not the test passes and I am able create buckets, keys and all that riak
was built for.

But, the riak seems have bound itself to the loopback address how do i make
make i bind it my LAN ip?

Sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100119/01fe867b/attachment.html>


More information about the riak-users mailing list