logging clues?

Ken Sedgwick ksedgwic at bonsai.com
Thu Jan 21 13:09:16 EST 2010


On 01/21/2010 06:34 AM, Bryan Fink wrote:
> On Tue, Jan 19, 2010 at 9:44 PM, Ken Sedgwick<ksedgwic at bonsai.com>  wrote:
>> I'm having trouble finding the ./start-logger.sh mentioned in the directions
>> here:
>>
>>     http://riak.basho.com/basic-setup.html
>
> Hi, Ken.  The start-logger script went away with the conversion to the
> rebar build system, but we forgot to update the logger documentation.
> The running log can now be viewed with the riak-admin script:
>
>     riak$ rel/riak/bin/riak-admin logger riak at 127.0.0.1 riak
>
> The first parameter (after 'logger') is the name of the node to which
> to connect, and the second parameter is the Erlang cookie for that
> node.
>
> I'm not sure about the RST you're seeing.  What operating system are
> you using?  We've found that TCP performance on OS X under heavy
> concurrent load is pretty awful, and could cause symptoms like this,
> for example.

I'm seeing the RST behavior when the client and riak node are both 
running on my laptop:

Fedora release 11 (Leonidas)

Linux lap3.bonsai.com 2.6.30.10-105.fc11.x86_64 #1 SMP Thu Dec 24 
16:41:51 UTC 2009 x86_64 x86_64 x86_64 GNU/Linux

I'll give it a quick try w/ the log running, to see if there is any 
additional information.

Thanks!

Ken

-- 
Ken Sedgwick
Bonsai Software, Inc.
http://www.bonsai.com/ken/
(510) 610-4162
ken+5a4 at bonsai.com
Public Key: http://www.bonsai.com/ken/ken.asc
GPG Fingerprint: 851E 3B07 E586 0843 9434  5CC7 4033 3B9B 3F3F 9640




More information about the riak-users mailing list