basho bench 64 bit

Michael Colussi mcolussi at gmail.com
Fri Jul 23 20:32:51 EDT 2010


Has anyone tried compiling basho bench on 64 bit linux?  Debian in
particular?

I get this error when I run make:

./rebar get-deps
==> protobuffs (get-deps)
==> riakc (get-deps)
==> casbench (get-deps)
==> ibrowse (get-deps)
==> stats (get-deps)
==> basho_bench (get-deps)
./rebar compile test escriptize
==> protobuffs (compile)
==> protobuffs (test)
==> protobuffs (escriptize)
==> riakc (compile)
==> riakc (test)
==> riakc (escriptize)
==> casbench (compile)
==> casbench (test)
==> casbench (escriptize)
==> ibrowse (compile)
/usr/bin/ld: skipping incompatible
/home/mcolussi/gateway/cirrus/sdk/cirrus-sdk-linux/lib/erlang/lib/erl_interface-3.6.5/lib/liberl_interface.a
when searching for -lerl_interface
/usr/bin/ld: cannot find -lerl_interface
collect2: ld returned 1 exit status
ERROR: $CC c_src/ibrowse_drv.o $LDFLAGS $DRV_LDFLAGS -o priv/ibrowse_drv.so
failed with error: 1
make: *** [all] Error 1'

I have a 32 bit build of erlang and riak.  Is there a way to specify basho
bench to build 32 bit as well?

Thanks,
Mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100723/ccae788d/attachment.html>


More information about the riak-users mailing list