Protocol Buffer Timeouts

Dan Reverri dan at basho.com
Fri Jul 30 14:56:42 EDT 2010


Hi Misha,

Justin was kind enough to point me in the right direction regarding your
question. You are referring to the default timeout applied to
gen_server:call/2. This does appear to be a bug in the client; I will file a
ticket in Bugzilla.

Thanks,
Dan

Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com


On Fri, Jul 30, 2010 at 11:11 AM, Dan Reverri <dan at basho.com> wrote:

> Hi Misha,
>
> Where in riakc_pb_socket do you see a 5 second timeout? Are you using the
> 0.2.0 or the latest tip? There is an issue in 0.2.0 where map reduce
> messages are not handled correctly which is fixed in the latest tip.
>
> Thanks,
> Dan
>
> Daniel Reverri
> Developer Advocate
> Basho Technologies, Inc.
> dan at basho.com
>
>
>
> On Fri, Jul 30, 2010 at 9:48 AM, Misha Gorodnitzky <misaka at pobox.com>wrote:
>
>> Hello all,
>>
>> We're doing some load testing using Riak erlang protocol buffers
>> interface and are running into timeouts. From the looks of it, the
>> timeouts are coming from the gen_server:calls in riakc_pb_socket.erl
>> which don't specify a timeout, meaning that they timeout after 5
>> seconds and we lose any reply that may come back from Riak (in our
>> case, the request to Riak typically completes despite the timeout).
>>
>> What's the best way to handle these timeouts? We could just increase
>> the timeout period in the calls, it seems odd to only give the Riak
>> client code 5 seconds when Riak could potentially take longer to
>> respond. Is this a bug?
>>
>>
>> --Misha
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100730/5f7364e7/attachment.html>


More information about the riak-users mailing list