[ANN] Ripple 0.7.0 - the Ruby Riak client

Sean Cribbs sean at basho.com
Thu May 6 20:52:01 EDT 2010


Riak Rubyists,

I've just tagged and released new gems for the Ruby Riak client, ripple.  It is compatible with the Riak 0.10 series -- HTTP interface only.  

The primary change in this release is support for ActiveSupport 2.3.5 in the lower-level library 'riak'.  This allows you to use the basic client library in scenarios (especially legacy apps) where you can't depend on the prerelease Rails 3 gems.  The 'ripple'  namespace/gem still requires the Rails 3 beta version of ActiveModel.

In addition, there are some new features including an ActiveSupport cache store and a preliminary implementation of embedded documents via associations.

There's more information about the changes in the release notes: http://github.com/seancribbs/ripple/blob/v0.7.0/RELEASE_NOTES.textile

A complete changeset history is here: http://github.com/seancribbs/ripple/compare/v0.6.1...v0.7.0

Sean Cribbs <sean at basho.com>
Developer Advocate
Basho Technologies, Inc.
http://basho.com/





More information about the riak-users mailing list