Problem running Innostore at Mac OS X

Dmitry Demeshchuk demeshchuk at gmail.com
Mon May 17 16:33:14 EDT 2010


No, it's Intel, Core 2 Duo. That makes the problem even more weird.
The other bad news is that I cannot find any core dumps from Erlang...

On Mon, May 17, 2010 at 7:41 PM, Ryan Tilder <rtilder at basho.com> wrote:
> Which hardware platform are you running on?  I'm guessing PowerPC.  Bus
> errors pretty much don't happen on x86 platforms any more.  If you haven't
> filed a bug with the full output of the error, please do so.  We can't do
> much for you without more detailed info.
> --Ryan
> On Sun, May 16, 2010 at 2:12 AM, Dmitry Demeshchuk <demeshchuk at gmail.com>
> wrote:
>>
>> Greetings.
>>
>> I'm running Mac OS X 10.5.8. Riak 0.10.1 is compiled and works good.
>> However, when I install Innostore like described at the wiki page and
>> try to perform any operations with Riak, node goes down.
>>
>> When I start riak using `bin/riak console`, everything seems to work good:
>>
>> 100516 12:48:13 Embedded InnoDB 1.0.6.6750 started; log sequence number
>> 44243
>>
>> But when I try to get keys from a bucket, to put any data using basic
>> Erlang interface (either from the other Erlang node or from the opened
>> console), Riak crashes with bus error.
>> I tried to start Riak as root but with the same result. Then thought
>> that perhaps free disk space is too low (about 12 GB) and freed some
>> space (up to about 20 GB) but still get the same result. Also, tried
>> to turn SMP on and off - still no result.
>>
>> I'm going to try installing it on my FreeBSD machine, will write about
>> the results.
>>
>> --
>> Best regards,
>> Dmitry Demeshchuk
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>



-- 
Best regards,
Dmitry Demeshchuk




More information about the riak-users mailing list