Riak changing the first two bytes of data?

Sam Tingleff sam at tingleff.com
Fri May 28 17:58:55 EDT 2010


Yeah, you're right... I'm sending as application/octet-stream. Is there some
special handling depending on content-type?

On Fri, May 28, 2010 at 2:56 PM, Sean Cribbs <sean at basho.com> wrote:

> It seems more than just the first two bytes are changed.  What content-type
> are you sending the data as?
>
> Sean Cribbs <sean at basho.com>
> Developer Advocate
> Basho Technologies, Inc.
> http://basho.com/
>
> On May 28, 2010, at 5:46 PM, Sam Tingleff wrote:
>
> >
> > It sounds crazy, I know.
> >
> > I'm using the Java client with riak 0.10.1-1. Sending a byte array seems
> to work if it is a UTF-8 encoded string. But if I send serialized object
> data, or just compressed bytes, the first two bytes seem to come back
> modified on read.
> >
> > From the debugger... Sending:
> > [31, -117, 8, 0, 0, 0, 0, 0, 0, 0, -53, 72, -51, -55, -55, 87, 72, 41,
> 77, 73, 5, 0, 108, 24, 72, 30, 10, 0, 0, 0]
> >
> > I get back:
> > [31, 63, 8, 0, 0, 0, 0, 0, 0, 0, -24, 72, -22, -125, -125, 87, 72, 41,
> 77, 73, 5, 0, 108, 24, 72, 30, 10, 0, 0, 0]
> >
> > What's going on? Thanks!
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20100528/21db4211/attachment.html>


More information about the riak-users mailing list