Innostore crash - force recovery not working via innodump

David Smith dizzyd at basho.com
Fri Nov 19 23:54:32 EST 2010


On Fri, Nov 19, 2010 at 2:26 PM, Rudy X. Desjardins <rudy at sandbenders.ca> wrote:
>
> I've tried to run innodump (from /priv in the innostore src/build dir)
> to dump the data with no luck - I get the same error message (first
> one, below) as when I just try to re-start the Riak node, unless I use
> -force_recovery 6 (all other levels produce original error), which
> produces the second error below.

> Any ideas how I might go about fixing this, or should I assume that
> node/data is dead/lost and just re-initialize the innostore for this
> node from scratch?

Unfortunately, it looks look Inno is truly and irrevocably unhappy
here. Your best bet to is to assume the node is dead/lost and
re-initialize the innostore accordingly. Read-repair should take care
of rebuilding the missing data from other replicas over time.
Depending on your load profile and key access distribution, this may
impose additional load on your cluster as reads will generate writes
to repair the missing data.

Have you considered using bitcask? It has a slightly better recovery
story, imnsho... :)

D.




More information about the riak-users mailing list