Error installing riak from source on OS X

David Smith dizzyd at basho.com
Sat Nov 27 10:30:21 EST 2010


On Fri, Nov 26, 2010 at 11:47 PM, Jonah Crawford
<jonah at microgridsystems.com> wrote:
> Hi I've been able to get riak funning using brew but getting some glitches with client code so I decided to install from source to see if it helps any. Here is the error I'm getting:

The root question here is "how did you install Erlang"? I suspect that
your Erlang install does not include support for SSL/crypto, so rebar
is blowing up. An easy way to verify this is to do the following on
the command line:

1. Start up erl (the erlang interpreter)
2. On the erl prompt type:

    crypto:start().

If all goes well, you should see something like:

(dizzyd at drekar).(~)% erl
Erlang R13B04 (erts-5.7.5) [source] [64-bit] [smp:2:2] [rq:2]
[async-threads:0] [hipe] [kernel-poll:false]

Eshell V5.7.5  (abort with ^G)
1> crypto:start().
ok
2>

Hope that helps...

D.




More information about the riak-users mailing list