Error installing riak from source on OS X

Jeremiah Peschka jeremiah.peschka at gmail.com
Sat Nov 27 10:41:26 EST 2010


If you pull from github using the instructions
here<http://wiki.basho.com/display/RIAK/Building+a+Development+Environment>,
it doesn't require the mercurial repository. I can only say that with any
confidence because I just pulled it down the source and tried it out.

I do recall running into this problem several months ago.

David has the right question: "how did you install Erlang?" I installed mine
through homebrew (Erlang R14B (erts-5.8.1) [source] [64-bit] [smp:4:4]
[rq:4] [async-threads:0] [hipe] [kernel-poll:false])

Eshell V5.8.1  (abort with ^G)
<http://wiki.basho.com/display/RIAK/Building+a+Development+Environment>
Jeremiah Peschka
Microsoft SQL Server MVP
MCITP: Database Developer, DBA
614.515.0727


On Sat, Nov 27, 2010 at 10:20 AM, Alexander Sicular <siculars at gmail.com>wrote:

> I believe you need to have mercurial installed. I think rebar looks for it
> even though the primary repos are in git now.
>
> -Alexander
>
>
> On Nov 27, 2010, at 10:16 AM, Jeremiah Peschka wrote:
>
> > Did you pull down the riak sources by cloning the github repo or did you
> just download from somewhere?
> >
> > Jeremiah Peschka
> > SQL Server MVP
> > MCITP: Database Developer, DBA
> > 614.515.0727
> >
> > On Nov 27, 2010 1:47 AM, "Jonah Crawford" <jonah at microgridsystems.com>
> wrote:
> > > Hi I've been able to get riak funning using brew but getting some
> glitches with client code so I decided to install from source to see if it
> helps any. Here is the error I'm getting:
> > >
> > > abort: There is no Mercurial repository here (.hg not found)
> > > ./rebar get-deps
> > > Uncaught error in rebar_core: {'EXIT',
> > > {undef,
> > > [{crypto,start,[]},
> > > {rebar_core,run,1},
> > > {rebar,main,1},
> > > {escript,run,2},
> > > {escript,start,1},
> > > {init,start_it,1},
> > > {init,start_em,1}]}}
> > >
> > > =ERROR REPORT==== 26-Nov-2010::22:40:37 ===
> > > Error in process <0.30.0> with exit value:
> {badarg,[{erlang,system_info,[build_type]},{crypto,on_load,0},{code_server,'-handle_on_load/4-fun-0-',1}]}
> > >
> > > make: *** [deps] Error 1
> > >
> > >
> > >
> > > Obviously it's looking for something that's not there... what libs need
> to be installed or present in the build package for this to work ?
> > >
> > > Thanks in advance,
> > >
> > > Jonah
> > > _______________________________________________
> > > riak-users mailing list
> > > riak-users at lists.basho.com
> > > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20101127/9d7fc03d/attachment.html>


More information about the riak-users mailing list