Handoff repeatedly failing

Tony Novak tony at dapper.net
Wed Oct 6 14:23:54 EDT 2010


Sean,

So I shouldn't be concerned that it's trying to handoff the same vnode
multiple times?

Thanks again!
Tony

On Wed, Oct 6, 2010 at 10:32 AM, Sean Cribbs <sean at basho.com> wrote:

> Tony,
>
> That error occurs when trying to interact with a socket that is closed. I
> can assure you that it is harmless and that the message will no longer
> appear in 0.13.
>
>  Sean Cribbs <sean at basho.com>
> Developer Advocate
> Basho Technologies, Inc.
> http://basho.com/
>
> On Oct 6, 2010, at 1:27 PM, Tony Novak wrote:
>
> After recently adding a few additional nodes to a Riak cluster, I keep
> seeing repeated handoff failures like this one:
>
> =INFO REPORT==== 6-Oct-2010::17:05:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:05:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
> =INFO REPORT==== 6-Oct-2010::17:08:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:08:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
> =INFO REPORT==== 6-Oct-2010::17:11:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:11:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
> =INFO REPORT==== 6-Oct-2010::17:14:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:14:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
> =INFO REPORT==== 6-Oct-2010::17:17:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:17:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
> =INFO REPORT==== 6-Oct-2010::17:20:30 ===
> Starting handoff of partition riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 to 'riak at 10.217.31.183'
> (riak at 10.104.41.223)1>
> =ERROR REPORT==== 6-Oct-2010::17:20:56 ===
> Handoff sender riak_kv_vnode
> 1043318063368056673053607043667580944695787782144 failed error:{badmatch,
>
>                   {error,
>
>                    closed}}
> (riak at 10.104.41.223)1>
>
> There's no corresponding log entry on the receiving machine
> (10.217.31.183), but Riak seems to be fully alive and functional on both
> nodes.  (I can successfully run "riak-admin test" on all nodes in the
> cluster.)
>
> What's going on here?
>
> Thanks!
>
> Tony Novak
> tony at dapper.net
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20101006/114ea0a8/attachment.html>


More information about the riak-users mailing list