Riak search from a separate erlang node

Dan Reverri dan at basho.com
Thu Oct 14 02:20:29 EDT 2010


There are portions of the Riak Search client that are calling
riak:local_client/0. Bug #818 has been filed:
https://issues.basho.com/show_bug.cgi?id=818

<https://issues.basho.com/show_bug.cgi?id=818>Thanks,
Dan

Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com


On Wed, Oct 13, 2010 at 9:45 PM, Jebu Ittiachen <jebu at jebu.net> wrote:

> Hi,
>   I've been using riak from a remote erlang node with no issues via a
> riak_client connection to the riak node. However the riak_search_client
> seems to not support using it from a remote erlang node. Why is it that I
> cannot use search features from a remote node?
>
> {ok, R1} = riak_search:client_connect('riaksearch at 127.0.0.1').
> R1:parse_query(<<"blah">>,<<"blah">>).
> ** exception exit: {noproc,{gen_server,call,
>
> [riak_search_config,{get_schema,<<"blah">>},infinity]}}
>      in function  gen_server:call/3
>      in call from riak_search_client:parse_query/3
>
> whereas this is fine
> {ok, Ops1} = rpc:call('riaksearch at 127.0.0.1', R1, parse_query,
> [<<"blah">>,<<"blah">>]).
> {ok,[{term,<<"blah">>,[]}]}
>
>
> --
> Jebu Ittiachen
> jebu at jebu.net
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20101013/0c8ea2b0/attachment.html>


More information about the riak-users mailing list