OS X install issue

Dmitry Demeshchuk demeshchuk at gmail.com
Fri Sep 24 05:55:14 EDT 2010


Try to clear the "deps" directory.

On Fri, Sep 24, 2010 at 1:47 PM, Mark Jarecki <mjarecki at bigpond.net.au> wrote:
> I've now installed Mercurial,
>
> However, now get:
>
>        abort: There is no Mercurial repository here (.hg not found)
> ./rebar get-deps
> Uncaught error in rebar_core: {'EXIT',
>                                  {undef,
>                                      [{crypto,start,[]},
>                                       {rebar_core,run,1},
>                                       {rebar,main,1},
>                                       {escript,run,2},
>                                       {escript,start,1},
>                                       {init,start_it,1},
>                                       {init,start_em,1}]}}
>
> =ERROR REPORT==== 24-Sep-2010::19:45:31 ===
> Error in process <0.30.0> with exit value: {badarg,[{erlang,system_info,[build_type]},{crypto,on_load,0},{code_server,'-handle_on_load/4-fun-0-',1}]}
>
> make: *** [deps] Error 1
>
> Where to from here?
>
>
> On 24/09/2010, at 7:31 PM, Dmitry Demeshchuk wrote:
>
>> You need to install mercurial to your workstation.
>>
>> You can either use their official site http://mercurial.selenic.com/
>> or install it from macports if you have them, using "port install
>> mercurial" command.
>>
>> Also, as far as I remember, you'll need git SCM as well:
>> http://git-scm.com/
>> or
>> sudo port install git-core
>>
>> On Fri, Sep 24, 2010 at 1:24 PM, Mark Jarecki <mjarecki at bigpond.net.au> wrote:
>>> Hi there,
>>>
>>> I'm trying to install Riak 0.12 on OS X 10.6.4 using Erlang R13B04.
>>>
>>> When I go into the Riak folder and type:
>>>
>>>        make rel
>>>
>>> I get:
>>>
>>>        make: hg: Command not found
>>> ./rebar get-deps
>>> Uncaught error in rebar_core: {'EXIT',
>>>                                  {undef,
>>>                                      [{crypto,start,[]},
>>>                                       {rebar_core,run,1},
>>>                                       {rebar,main,1},
>>>                                       {escript,run,2},
>>>                                       {escript,start,1},
>>>                                       {init,start_it,1},
>>>                                       {init,start_em,1}]}}
>>>
>>> =ERROR REPORT==== 24-Sep-2010::19:22:42 ===
>>> Error in process <0.30.0> with exit value: {badarg,[{erlang,system_info,[build_type]},{crypto,on_load,0},{code_server,'-handle_on_load/4-fun-0-',1}]}
>>>
>>> make: *** [deps] Error 1
>>>
>>>
>>> Any ideas on how to fix the error?
>>>
>>> Cheers,
>>>
>>> Mark
>>>
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>
>>
>>
>> --
>> Best regards,
>> Dmitry Demeshchuk
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>



-- 
Best regards,
Dmitry Demeshchuk



More information about the riak-users mailing list