SV: Slow inserts

Jens Rantil jens.rantil at telavox.se
Tue Apr 12 04:50:32 EDT 2011


Hi again Dan,

The timings for the nodes can be found here:
http://pastebin.com/L1mwThPA

Regards,
Jens

Från: Dan Reverri [mailto:dan at basho.com]
Skickat: den 11 april 2011 21:57
Till: Jens Rantil
Kopia: riak-users at lists.basho.com
Ämne: Re: Slow inserts

What are the put_fsm timings across the nodes as reported by "riak-admin status" after running the script?
node_put_fsm_time_mean
node_put_fsm_time_median
node_put_fsm_time_95
node_put_fsm_time_99
node_put_fsm_time_100


Thanks,
Dan

Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com<mailto:dan at basho.com>

On Mon, Apr 11, 2011 at 12:37 PM, Jens Rantil <jens.rantil at telavox.se<mailto:jens.rantil at telavox.se>> wrote:
Hi,

By "not doing anything" I meant they were idling apart from the riak/Erlang processes running.

And yes, riak-admin status shows all five nodes according in ring_members according to [1].

[1] http://wiki.basho.com/Basic-Cluster-Setup.html
Thanks,
Jens

On 11 apr 2011, at 18:57, "Dan Reverri" <dan at basho.com<mailto:dan at basho.com>> wrote:
Can you explain what you mean by "Four of the nodes were not doing anything else"?

Does "riak-admin status" show the appropriate nodes in the ring?

Thanks,
Dan


Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com<mailto:dan at basho.com>

On Mon, Apr 11, 2011 at 9:00 AM, Jens Rantil <jens.rantil at telavox.se<mailto:jens.rantil at telavox.se>> wrote:
Hi,

I have set up a 5-node test environment to give Riak a test run. I wrote a Python script (http://pastebin.com/geQ00Ngb) that put 53780 key-values into my cluster. Using round robin, 11 threads inserted these values in ~70 seconds. This means an average of ~750 key-values/second. Is this the expected speed of inserts? It seems quite slow. The Mozilla benchmark (http://blog.mozilla.com/data/2010/08/16/benchmarking-riak-for-the-mozilla-test-pilot-project/) reached > 1500 ops/second for significantly bigger values than my benchmark.

Additional information:
* Four of the nodes were not doing anything else.
* n_val=3
* For every insert, w=1 and dw=0.
* All nodes are using riak_0.14.1-1_amd64.deb and I have not changed any of the defaults settings except Erlang -cookie and -name.

Thanks,
Jens Rantil

_______________________________________________
riak-users mailing list
riak-users at lists.basho.com<mailto:riak-users at lists.basho.com>
http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110412/3acca1d0/attachment.html>


More information about the riak-users mailing list