RiakSearch question

Rusty Klophaus rusty at basho.com
Wed Apr 13 15:23:00 EDT 2011


Hi Muhammad,

If you have './bin/riak', it means you have downloaded Riak KV, not Riak
Search. Riak Search would have the './bin/riaksearch' executable.

You can download Riak Search (including src code) from here:
http://downloads.basho.com/riak-search/CURRENT/

<http://downloads.basho.com/riak-search/CURRENT/>If you are adventurous, the
latest source code is available from here:
http://github.com/basho/riak_search. As I stated in a previous email, that's
our active development branch, so it's not always guaranteed to be 100%
operational.

Best,
Rusty

On Wed, Apr 13, 2011 at 2:00 PM, Muhammad Yousaf
<muhammad.yousaf at live.com>wrote:

>
>
>
> I already have that repo. I think i am doing something wrong. Let me
> explain you again in detail
> I have separte Riak and Riak_Search repo
>
> I was using Riak_Search to setup my schema and i have inserted and retrieve
> values in my bucket using erlang client like
>
>     {ok,Client} =riakc_pb_socket:start_link("127.0.0.1",8087),
>     InsertObject =
> riakc_obj:new(list_to_binary(Bucket),list_to_binary(Key),List),
>
> one single riak node.
>
> Now i want to configure multiple node riak cluster, to follow
> http://wiki.basho.com/Building-a-Development-Environment.html instruction
> i have to stop riaksearch and start riak. After setting three node cluster
> object of erlang client is unaware of bucket information that i setup on
> riak_search
>
> for example
>
> ubuntu$ riaksearch start
> Attempting to restart script through sudo -u riak
> ubuntu$ erl -name client at 127.0.0.1 -setcookie riak -pa
> ~/riak-erlang-client/ebin ~/riak-erlang-client/deps/*/ebin -pa
> ~/riak-erlang-client/deps/protobuffs/ebin/
> Erlang R14B01 (erts-5.8.2) [source] [64-bit] [smp:2:2] [rq:2]
> [async-threads:0] [kernel-poll:false]
>
> Eshell V5.8.2  (abort with ^G)
> (client at 127.0.0.1)1> {ok, Pid} = riakc_pb_socket:start_link("127.0.0.1",
> 8087).
> {ok,<0.39.0>}
> (client at 127.0.0.1)12> riakc_pb_socket:search(Pid, <<"user">>,
> "fname:umesh").
> {ok,[[<<"user">>,<<"umesh">>]]}
>
>
> but now if i do like that
>
>
> dev1/bin/riak start
>
> (client at 127.0.0.1)8> {ok,Pid}= riakc_pb_socket:start_link("127.0.0.1",8087).
> {ok,<0.53.0>}
>
> (client at 127.0.0.1)10> riakc_pb_socket:search(Pid, <<"user">>, "fname:umesh").
>
> =ERROR REPORT==== 13-Apr-2011::19:54:51 ===
> ** Generic server <0.53.0> terminating
> ** Last message in was {tcp_closed,#Port<0.753>}
> ** When Server state == {state,"127.0.0.1",8087,false,false,undefined,
>                                undefined,
>                                {[],[]},
>                                1,[],infinity,100}
> ** Reason for termination ==
> ** disconnected
> ** exception exit: disconnected
>
> any idea what i am doing wrong ?
>
>
>
> Regards,
>
> Muhammad Yousaf
>
>
>
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110413/5d4f9e39/attachment.html>


More information about the riak-users mailing list