Attempting to use secondary indexes

Kelly McLaughlin kelly at basho.com
Thu Aug 4 00:02:53 EDT 2011


Craig,

The default backend is bit cask and if you want to use the indexes you'll need to look in etc/app.config in the release directory and change the value for the storage_backend setting to riak_kv_index_backend instead of riak_kv_bitcask_backend. I suspect that's the problem. Cheers.

Kelly


On Aug 3, 2011, at 9:42 PM, Craig Muth wrote:

> I'm running the code example from http://rusty.basho.com.s3.amazonaws.com/Presentations/2011-OSCONData-Portland.pdf
> 
> This succeeds:
> curl \
>   -X PUT \
>   -d "OPAQUE_VALUE" \
>   -H "x-riak-index-category_bin: armor" \
>   -H "x-riak-index-price_int: 400" \
>   http://127.0.0.1:8098/buckets/loot/keys/gauntlet24
> 
> This verifies it's getting there:
> curl http://127.0.0.1:8098/riak/loot/gauntlet24
>   => OPAQUE_VALUE
> 
> However, this finds nothing:
> curl http://127.0.0.1:8098/buckets/loot/index/category_bin/eq/armor
>   => {"keys":[]}
> 
> Whereas in the presentation it says it should return {"keys":["gauntlet24"]}
> 
> Any ideas?  Just grabbed the latest from github master.
> 
> --Craig
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110803/516c53d2/attachment.html>


More information about the riak-users mailing list