object not stored

Giancarlo Frison gfrison at chelab.com
Wed Aug 31 12:30:07 EDT 2011


Previously I caught not found in HTTP interface and in PB client as well.

Now I set w/dw to 2 (leaving n_val=3 as default) and I didn't see the
problem again, but a delay from the store and a successful fetch (after a 1
sec).
If I fetch the obj immediately after the store I caught not found again
(sometimes).

How can I find it soon after the store?

But I think it's better to set n_val =1 with a this development-1node setup,
isn't it?


Giancarlo Frison



On Wed, Aug 31, 2011 at 5:45 PM, Mark Steele <msteele at beringmedia.com>wrote:

> I would think that one of the following would work:
>
> Make your n_val = 1 on the bucket and set or R/W/DW = 1 on
> reads/writes/deletes
>
> OR
>
> Leave the n_val at 3 (the default), make the R/W/DW = 2 (quorum) on
> reads/writes/deletes.
>
>
>
> On Wed, Aug 31, 2011 at 11:36 AM, Giancarlo Frison <gfrison at chelab.com>wrote:
>
>> This is the bucket conf:
>>
>> gfrison at gfw:~$ curl http://localhost:8098/riak/user
>>
>> {"props":{"name":"user","n_val":3,"allow_mult":false,"last_write_wins":false,"precommit":[],"postcommit":[],"chash_keyfun":{"mod":"riak_core_util","fun":"chash_std_keyfun"},"linkfun":{"mod":"riak_kv_wm_link_walker","fun":"mapreduce_linkfun"},"old_vclock":86400,"young_vclock":20,"big_vclock":50,"small_vclock":10,"r":"quorum","w":"quorum","dw":"quorum","rw":"quorum"}}
>>
>> the server is single instance, the configuration is the default, no
>> changes.
>>
>> I store the object as:
>>
>> rc.store(ob, new StoreMeta(1, 1, true))
>> w=1,dw=1,returnbody=true
>>
>>
>> Can you help me?
>>
>> Giancarlo Frison
>>
>>
>>
>> On Wed, Aug 31, 2011 at 4:01 PM, Jonathan Langevin <
>> jlangevin at loomlearning.com> wrote:
>>
>>> That could occur, depending on how many nodes are in your cluster, what
>>> your r/w/dw settings are set to when fetching the object, how soon after
>>> storing you attempt to fetch.
>>> What is your configuration? i.e. - how many nodes in your cluster, what
>>> settings are you using for reading & writing to Riak (r/w/dw, etc), what are
>>> your bucket settings set to?
>>>
>>> I'm not advanced enough to help, but that info should hopefully help the
>>> others on the list ;-)
>>> *
>>>
>>>  <http://www.loomlearning.com/>
>>>  Jonathan Langevin
>>> Systems Administrator
>>> Loom Inc.
>>> Wilmington, NC: (910) 241-0433 - jlangevin at loomlearning.com -
>>> www.loomlearning.com - Skype: intel352
>>> *
>>>
>>>
>>> On Wed, Aug 31, 2011 at 9:29 AM, Giancarlo Frison <gfrison at chelab.com>wrote:
>>>
>>>> Hi all,
>>>>
>>>> Sometimes happen that storing object with PB client doesn't work, the
>>>> snippet is:
>>>>
>>>> IRiakObject ob =
>>>> RiakObjectBuilder.newBuilder(bucket,key).withContentType("application/json").withValue(json).build();
>>>>  return rc.store(ob, new StoreMeta(1, 1, true)).getVclock().getBytes();
>>>>
>>>> below it is the snoop of storing action. As you can see the riak server
>>>> is invoked by the client and return the object:
>>>>
>>>> T 127.0.0.1:52015 -> 127.0.0.1:8087 [AP]
>>>> .....
>>>> .user..gfrison"..
>>>>
>>>> G{"name":"Giancarlo","id":"gfrison","password":"pwd","surname":"frison"}..application/json;charset=utf-82"
>>>> .eclass-general_domain..User..iof(.0.8.
>>>> ##
>>>> T 127.0.0.1:8087 -> 127.0.0.1:52015 [AP]
>>>> .....
>>>> ..
>>>>
>>>> G{"name":"Giancarlo","id":"gfrison","password":"pwd","surname":"frison"}..application/json;charset=utf-8*.4fXUimzXj3g0ukJHcpuxm32"
>>>> .eclass-general_domain..User..iof8.....@
>>>> ..).*k.a```.`..R,..E..L..y....W..A....L.
>>>> ?..g..
>>>>
>>>>
>>>> but when I try to get such object, I got not found:
>>>>
>>>>  gfrison at ttw:~$ curl http://localhost:8098/riak/user/gfrison
>>>> not found
>>>>
>>>> Have you any hint on it?
>>>>
>>>> thanks!
>>>>
>>>>
>>>>
>>>> Giancarlo Frison
>>>> @gfrison
>>>>
>>>>
>>>> _______________________________________________
>>>> riak-users mailing list
>>>> riak-users at lists.basho.com
>>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>>
>>>>
>>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110831/8971dc6d/attachment.html>


More information about the riak-users mailing list