error: unpacking of archive failed on file /usr/lib64/riak/erts-5.7.5/bin/beam; 4d53dbb2: cpio: Digest mismatch

Mike Stoddart stodge at gmail.com
Thu Feb 10 07:38:50 EST 2011


I'm trying to install Riak on Fedora 12 using the RPM from Basho's
download site. I'm getting a digest mismatch error - does this mean my
Fedora is subtly different from the one used to build the original
RPM?

Thanks
Mike



 yum install --nogpgcheck
~mike//download/downloads.basho.com/riak/CURRENT/riak-0.14.0-1.fc12.x86_64.rpm
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Examining /home/mike//download/downloads.basho.com/riak/CURRENT/riak-0.14.0-1.fc12.x86_64.rpm:
riak-0.14.0-1.fc12.x86_64
Marking /home/mike//download/downloads.basho.com/riak/CURRENT/riak-0.14.0-1.fc12.x86_64.rpm
to be installed
Resolving Dependencies
--> Running transaction check
---> Package riak.x86_64 0:0.14.0-1.fc12 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================
 Package       Arch            Version                 Repository
                     Size
=================================================================================================
Installing:
 riak          x86_64          0.14.0-1.fc12
/riak-0.14.0-1.fc12.x86_64           31 M

Transaction Summary
=================================================================================================
Install       1 Package(s)

Total size: 31 M
Installed size: 31 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : riak-0.14.0-1.fc12.x86_64
                      1/1
Error unpacking rpm package riak-0.14.0-1.fc12.x86_64
error: unpacking of archive failed on file
/usr/lib64/riak/erts-5.7.5/bin/beam;4d53dbb2: cpio: Digest mismatch

Failed:
  riak.x86_64 0:0.14.0-1.fc12

Complete!
[root at wv1 ~]# yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
No Packages marked for Update
[root at wv1 ~]# yum upgrade
Loaded plugins: presto, refresh-packagekit
Setting up Upgrade Process
No Packages marked for Update




More information about the riak-users mailing list