riak-search build assumes access to github using 'git' protocol

Mike Stoddart stodge at gmail.com
Thu Feb 17 12:30:05 EST 2011


I was running make rel using the tar ball but it kept complaining
about git as I mentioned. I tried ./rebar compile but I get:

==> erlang_js (compile)
Compiled src/js_drv_comm.erl
Compiled src/js_benchmark.erl
Compiled src/js_memory.erl
Compiled src/erlang_js.erl
Compiled src/erlang_js_sup.erl
Compiled src/js.erl
Compiled src/js_mochinum.erl
Compiled src/js_cache.erl
Compiled src/js_driver.erl
Compiled src/js_mochijson2.erl
ERROR: compile failed while processing
/home/mike/download/riak_search-0.14.0/deps/erlang_js:
{'EXIT',{function_clause,[{lists,thing_to_list,[{error,bad_name}]},
                          {lists,flatmap,2},
                          {lists,flatmap,2},
                          {rebar_port_compiler,default_env,0},
                          {rebar_port_compiler,compile,2},
                          {rebar_core,run_modules,4},
                          {rebar_core,execute,4},
                          {rebar_core,process_dir,4}]}}

Thanks
Mike

On Thu, Feb 17, 2011 at 12:03 PM, Jon Meredith <jmeredith at basho.com> wrote:
> Did you try downloading the tarball from riak_search-0.14.0-1.tar.gz and
> running make?
> If that fails you could try running
> ./rebar compile
> ./rebar rel
> And that should build the release in rel/riak
> BR, Jon.
>
> On Thu, Feb 17, 2011 at 9:57 AM, Mike Stoddart <stodge at gmail.com> wrote:
>>
>> I'm trying to build riak-serach at work but our corporate firewall
>> blocks the 'git' protocol. I can only download via http or https. I've
>> tried changing rebar.config to use the URLs for https instead but I
>> get errors:
>>
>> fatal: Not a git repository (or any of the parent directories): .git
>>
>> Any ideas how to get this to build on Fedora 12 64bit?
>>
>> Thanks
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>




More information about the riak-users mailing list