erlang client

Qvin . at
Fri Jan 7 23:16:12 EST 2011

That was it. Thank you so much.

Subject: Re: erlang client
From: jon at
Date: Fri, 7 Jan 2011 20:24:35 -0600
CC: riak-users at
To: at

Looks like you're trying to connect to the HTTP port using the Protobuff client.
2> {ok, Pid}=riakc_pb_socket:start_link("", 8098).

The examples show:
1> {ok, Pid} = riakc_pb_socket:start_link("", 8087).
Port 8098 is the default port for HTTP.

Thanks!Jon Brisbin
        Web:    Twitter: @j_brisbin      Skype: jon.brisbin

On Jan 7, 2011, at 7:54 PM, Qvin . wrote:
I am trying to connect to riak using the riak-erlang-client v1.0.2 from but I've not been successful. I get the error listed below - 
2> {ok, Pid}=riakc_pb_socket:start_link("", 8098).
3> Pid.
4> riakc_pb_socket:ping(Pid).

=ERROR REPORT==== 7-Jan-2011::20:37:22 ===
** Generic server <0.35.0> terminating 
** Last message in was {req_timeout,#Ref<>}
** When Server state == {state,"",8098,false,false,undefined,
** Reason for termination == 
** disconnected
** exception exit: disconnected
I am running riak 0.14 and I know that it's working fine as I am able to connect to it through the http interface.  I have erlang R13B04 installed. I tried this on Ubuntu 10.10 with erlang R13B03 installed and I had the same problem. 
Any suggestions? Is this is a erlang client issue?
Thanks in advance,

riak-users mailing list
riak-users at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the riak-users mailing list