No results provided by Riak search, another !

Germain Maurice germain.maurice at linkfluence.net
Tue Jul 5 10:05:08 EDT 2011


Hello everybody,

I have a problem with Riak Search. I tried to find the solution by my 
own, i tried all the solutions i found and no results.

Firstly, i tried to use it with the default schema, it works but it 
indexes too much data.
So, i set my own schema as this :
{
     schema,
     [
         {version, "1.1"},
         {n_val, 1},
         {default_field, "nsid"},
         {analyzer_factory, {erlang, text_analyzers, 
standard_analyzer_factory}}
     ],
     [
         {field, [
             {name, "favedate"},
             {type, string},
             {analyzer_factory, {erlang, text_analyzers, 
standard_analyzer_factory}}
         ]},

         {field, [
             {name, "date_faved"},
             {type, string},
             {analyzer_factory, {erlang, text_analyzers, 
standard_analyzer_factory}}
         ]},

         %% Everything else is skipped
         {dynamic_field, [
             {name, "*"},
             {skip, true}
         ]}
     ]
}.

Hook on precommit of my buckets are ok.
I set the schema for each of my buckets as this : "search-cmd set-schema 
photostest My.schema"
Did a "search-cmd clear-schema-cache" command.

I re-indexed all of my documents of the bucket however, these documents 
are not indexed.
An example :

{ "fans":{
     "data":[{"nsid":"83786678 at N00",
             "favedate":"1309539453"}
               ,{"nsid":"33233619 at N02",
                "favedate":"1309539169"}]
  , ...
Here is the answer of the index :
{"responseHeader":{"status":0,"QTime":2,"params":{"q":"fans_data_nsid:83786678 at N00","q.op":"or","filter":"","wt":"
json"}},"response":{"numFound":0,"start":0,"maxScore":"0.0","docs":[]}}


thank you !

-- 
Germain Maurice
Administrateur Système/Réseau
Tel : +33.(0)1.42.43.54.33

http://www.linkfluence.net





More information about the riak-users mailing list