problem building on CentOS 64bit

Sean Cribbs sean at basho.com
Fri Jul 8 14:08:00 EDT 2011


Phil,

This is a question best sent to the riak-users list.  Recent changes in the
codebase necessitate an upgrade to rebar. In your source checkout, download
rebar from here:  https://github.com/downloads/basho/rebar/rebar ... then
re-attempt the build.

On Fri, Jul 8, 2011 at 2:01 PM, Phil Stanhope <stanhope at gmail.com> wrote:

> Hi all,
>
> Environment = CentOS 64bit 5.6
>
> I've got working 13B04 (from source) + .14.2 ... no problems there.
>
> I've got a working 14B02 (from source) ... no problems there.
>
> I've cloned RIAK from github today. Have two problems while building:
>
> erlang_js ... need to modify Makefile to explicitly set --enable-64bit
> eleveldb ... need to modify leveldb/Makefile to explicitly set -fPIC
>
> NOTE: When I pull the individual repos directly, they build fine. It's only
> when pulling RIAK and rebar has done the get_deps process that I've got the
> problem.
>
> It seems that there are commits in either of the dependent repositories for
> these fixes.
>
> I just don't know how rebar does it's dependency magic (yet) to understand
> what commit it's pulling from github.
>
> -phil
>



-- 
Sean Cribbs <sean at basho.com>
Developer Advocate
Basho Technologies, Inc.
http://www.basho.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110708/43f3c22e/attachment.html>


More information about the riak-users mailing list