Riak compile error: Module gen_server2 potentially included by two different applications: rabbit_common and riak_core

Brett Hoerner brett at bretthoerner.com
Wed Jul 27 11:19:06 EDT 2011


On Wed, Jul 27, 2011 at 10:09 AM, Sean Cribbs <sean at basho.com> wrote:
> That said, just move that application (rabbit_common) aside while building
> Riak and move it back after your release is built.

Thanks, this worked.

For what it's worth (if it comes up again), I'm using the default
Debian package for Rabbit which sets up a symlink:

/usr/lib/erlang/lib/rabbit_common -> ../../rabbitmq/lib/rabbitmq_server-2.3.1

If you remove it for the build it works just fine.

Brett




More information about the riak-users mailing list