Problems starting riak

Jason J. W. Williams jasonjwwilliams at gmail.com
Sat Jun 4 16:48:46 EDT 2011


Have you tried with Erlang R14B02?

Sent via iPhone

Is your email Premiere?

On Jun 4, 2011, at 5:25, Alvaro Videla <videlalvaro at gmail.com> wrote:

> Hi,
> 
> I'm trying to build riak using the latest Erlang release built with these options:
> 
> ./configure --enable-smp-support --enable-darwin-64bit --enable-kernel-poll
> 
> I've got riak using: git clone git://github.com/basho/riak.git
> 
> After I did *make rel* I tried bin/riak console
> 
> And I got the following errors:
> 
> The on_load function for module bitcask_nifs returned {error,
>                                                       {bad_lib,
>                                                        "Library version (1.0) not compatible (with 2.2)."}}
> 
> And:
> 
> =INFO REPORT==== 4-Jun-2011::14:20:15 ===
>    alarm_handler: {clear,{disk_almost_full,"/"}}
> {"Kernel pid terminated",application_controller,"{application_start_failure,riak_kv,{shutdown,{riak_kv_app,start,[normal,[]]}}}"}
> 
> If I run df -h it shows that I have available 32GB on my HD.
> 
> head erl_crash.dump 
> 
> =erl_crash_dump:0.1
> Sat Jun  4 14:20:16 2011
> Slogan: Kernel pid terminated (application_controller) ({application_start_failure,riak_kv,{shutdown,{riak_kv_app,start,[normal,[]]}}})
> System version: Erlang R14B03 (erts-5.8.4) [source] [64-bit] [smp:2:2] [rq:2] [async-threads:64] [hipe] [kernel-poll:true]
> 
> Here's the full output: https://gist.github.com/1007857
> 
> Any help or hints?
> 
> Cheers,
> 
> Alvaro
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com



More information about the riak-users mailing list