riak make fail

wilson Tuladhar mailwilson007 at gmail.com
Thu Mar 3 05:16:57 EST 2011


Hi,
Did you check if u are able to load the crypto module. If no then, try
downloading the latest version and run the install. It should solve the
issue.

/Wilson

On Thu, Mar 3, 2011 at 11:08 AM, Mohammad Shariq <shariqnitt at gmail.com>wrote:

> I have installed libssl-dev
> and  'Erlang R13B04' is already installed.
> the same error is coming again,
>
> Do I need to install erlang R14B01 ???
>
>
>
>
> On 3 March 2011 14:06, wilson Tuladhar <mailwilson007 at gmail.com> wrote:
>
>> Hi Mohammad,
>>
>> It seems that you don't have crypto module of erlang installed.
>>  *sudo apt-get install libssl-dev*
>> *
>> *
>> and then recompile the erlang and then this module should be installed.
>>
>> To check if it is installed, go to erlang shell and do
>> erl> l(crypto).
>> and you should get the module loaded reponse if not try to reinstall
>> erlang R14B01 again and it will get installed.
>>
>> Hope this helps.
>>
>> /Wilson
>>
>> On Thu, Mar 3, 2011 at 9:24 AM, Mohammad Shariq <shariqnitt at gmail.com>wrote:
>>
>>> Hi ,
>>> 'make all'  also produces the same error , Below is the error message :
>>>
>>> shariq at shariq-box:/mnt/riak-0.14.0$ sudo make all rel
>>>
>>>
>>> fatal: Not a git repository (or any of the parent directories): .git
>>> ./rebar get-deps
>>> fatal: Not a git repository (or any of the parent directories): .git
>>> fatal: Not a git repository (or any of the parent directories): .git
>>> fatal: Not a git repository (or any of the parent directories): .git
>>> Uncaught error in rebar_core: {'EXIT',
>>>                                   {undef,
>>>                                       [{crypto,start,[]},
>>>                                        {rebar_core,run,1},
>>>                                        {rebar,main,1},
>>>                                        {escript,run,2},
>>>                                        {escript,start,1},
>>>                                        {init,start_it,1},
>>>                                        {init,start_em,1}]}}
>>> make: *** [deps] Error 1
>>>
>>>
>>>  On 3 March 2011 11:17, Alexander Sicular <siculars at gmail.com> wrote:
>>>
>>>> try ?
>>>>
>>>> make all && make rel
>>>>
>>>> -Alexander Sicular
>>>>
>>>> @siculars
>>>>
>>>> On Mar 3, 2011, at 12:40 AM, Mohammad Shariq wrote:
>>>>
>>>> > Below is the Error Message :
>>>> >
>>>> > shariq at shariq-box:/mnt/riak-0.14.0$ sudo make rel
>>>> > fatal: Not a git repository (or any of the parent directories): .git
>>>> > ./rebar get-deps
>>>> > fatal: Not a git repository (or any of the parent directories): .git
>>>> > fatal: Not a git repository (or any of the parent directories): .git
>>>> > fatal: Not a git repository (or any of the parent directories): .git
>>>> > Uncaught error in rebar_core: {'EXIT',
>>>> >                                   {undef,
>>>> >                                       [{crypto,start,[]},
>>>> >                                        {rebar_core,run,1},
>>>> >                                        {rebar,main,1},
>>>> >                                        {escript,run,2},
>>>> >                                        {escript,start,1},
>>>> >                                        {init,start_it,1},
>>>> >                                        {init,start_em,1}]}}
>>>> > make: *** [deps] Error 1
>>>> >
>>>> >
>>>> > Make is failed.
>>>> >
>>>> >
>>>> >
>>>> >
>>>> > On 2 March 2011 21:30, Dan Reverri <dan at basho.com> wrote:
>>>> > Hi Shariq,
>>>> >
>>>> > You can ignore this particular error message; the build will still
>>>> work. Are you seeing any other error messages?  Is the build not working on
>>>> your system?
>>>> >
>>>> > Thanks,
>>>> > Dan
>>>> >
>>>> >
>>>> > Daniel Reverri
>>>> > Developer Advocate
>>>> > Basho Technologies, Inc.
>>>> > dan at basho.com
>>>> >
>>>> >
>>>> > On Wed, Mar 2, 2011 at 5:03 AM, Mohammad Shariq <shariqnitt at gmail.com>
>>>> wrote:
>>>> > Hello folk,
>>>> > I am trying to Install riak on my system , Ubuntu 10.10,    64 bit.
>>>> >
>>>> > I downloaded  "riak-0.14.0-1.tar.gz"
>>>> > unzip it and cd  INTO  riak-0.14.0
>>>> >
>>>> > Now I am running the command :     sudo make rel
>>>> >
>>>> > And I am getting the Error message :     "fatal: Not a git repository
>>>> (or any of the parent directories): .git"
>>>> >
>>>> >
>>>> >
>>>> > Please help me,  I tried googling but could'nt resolve my problem.
>>>> >
>>>> >
>>>> >
>>>> >
>>>> > --
>>>> > Thanks and Regards
>>>> > Shariq
>>>> >
>>>> >
>>>> >
>>>> > _______________________________________________
>>>> > riak-users mailing list
>>>> > riak-users at lists.basho.com
>>>> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>> >
>>>> >
>>>> >
>>>> >
>>>> >
>>>> > --
>>>> > Thanks and Regards
>>>> > Mohammad Shariq
>>>> >
>>>> >
>>>> > _______________________________________________
>>>> > riak-users mailing list
>>>> > riak-users at lists.basho.com
>>>> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>>
>>>>
>>>
>>>
>>> --
>>> Thanks and Regards
>>> Mohammad Shariq
>>>
>>>
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>>
>>
>
>
> --
> Thanks and Regards
> Mohammad Shariq
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110303/1bbab18a/attachment.html>


More information about the riak-users mailing list