/stats throws a 500 error

David Smith dizzyd at basho.com
Wed Mar 9 08:22:43 EST 2011


There was a bug fixed in 0.14.1 release:

https://issues.basho.com/show_bug.cgi?id=971

which has this symptom. Without knowing what version of Riak, the
amount of load you are exerting on the server, etc. it's hard to say
definitively if you are experiencing this specific issue. :)

D.

On Tue, Mar 8, 2011 at 4:10 PM, Mark Erdmann <mark.erdmann at gmail.com> wrote:
> When I try to access the /stats page, the node throws this 500 error:
> <html><head><title>500 Internal Server
> Error</title></head><body><h1>Internal Server Error</h1>The server
> encountered an error while processing this
> request:<br><pre>{error,{exit,{timeout,{gen_server2,call,[riak_kv_stat,get_stats]}},
>              [{gen_server2,call,2},
>               {riak_kv_wm_stats,get_stats,0},
>               {riak_kv_wm_stats,produce_body,2},
>               {webmachine_resource,resource_call,3},
>               {webmachine_resource,do,3},
>               {webmachine_decision_core,resource_call,1},
>               {webmachine_decision_core,decision,1},
>
>  {webmachine_decision_core,handle_request,2}]}}</pre><P><HR><ADDRESS>mochiweb+webmachine
> web server</ADDRESS></body></html>
> Does anyone know what could cause this?
> -Mark
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>



-- 
Dave Smith
Engineering Manager
Basho Technologies, Inc.
dizzyd at basho.com




More information about the riak-users mailing list