RiakSearch 14.0 All Gets/Puts Timing out on a single node system.

Dan Reverri dan at basho.com
Wed Mar 16 13:50:26 EDT 2011


You shouldn't need to recompile to make configuration changes. The
"rel/riaksearch/etc/app.config" file should be referenced by Riak Search
whenever the node is started.

When compiling a release the default values used for
"rel/riaksearch/etc/app.config" are defined by "rel/vars.config".

Thanks,
Dan

Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com


On Wed, Mar 16, 2011 at 10:40 AM, J T <jt4websites at googlemail.com> wrote:

> Unfortunately not, the log files are suspiciously quiet .. but I'm
> reasonably certain that I'm looking in the right place.
>
> However, I think I fixed the problem.
>
> After doing a *make rel* I went in and modified the etc config to have
> riak use an external ip address and I think its that that caused the
> problem.
>
> Instead I needed to make the change to *rel/vars.config* and then redo the
> *make rel* leading me to suspect that the values are actually compiled in
> somewhere and not just read from a config file on startup.
>
>
> On Wed, Mar 16, 2011 at 4:41 PM, Dan Reverri <dan at basho.com> wrote:
>
>> Hi JT,
>>
>> Are there any error messages in your Riak Search log files?
>>
>> Thanks,
>> Dan
>>
>> Daniel Reverri
>> Developer Advocate
>> Basho Technologies, Inc.
>> dan at basho.com
>>
>>
>> On Tue, Mar 15, 2011 at 5:13 PM, J T <jt4websites at googlemail.com> wrote:
>>
>>> Hi,
>>>
>>> I was running an older version of riak (v12) for a while and recently
>>> upgraded to riak_search (v14).
>>>
>>> I can connect to the node, I can ping it. But any put or get results in a
>>> timeout.
>>>
>>> There is a difference in deployment, previously I was running it on the
>>> same host as the client and accessing directly using the erlang client api
>>> (not pb).
>>> Now, I moved the node on a separate machine and can connect to it both
>>> from the original host and also locally on the same host.
>>>
>>> Following the instructions in README.txt to test, results in a pong from
>>> the ping but timeouts (after a long delay).
>>>
>>> I'm a bit stumped.  Any tips ?
>>>
>>> JT.
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110316/c4ea87d6/attachment.html>


More information about the riak-users mailing list