Error on riakc_pb_socket:put()

Dan Reverri dan at basho.com
Thu Mar 17 01:25:34 EDT 2011


Looks like you are using the wrong port number; "8091" is for HTTP. Try
"8081" to connect to the "dev1" node.

Thanks,
Dan

Daniel Reverri
Developer Advocate
Basho Technologies, Inc.
dan at basho.com


On Wed, Mar 16, 2011 at 10:22 PM, Saurabh Sehgal <saurabh.r.s at gmail.com>wrote:

> Hi,
>
> I followed the tutorial on the wiki to start storing some objects in riak.
> I was able to store them through the examples given with "curl", but get the
> following error when using the erlang client ->
>
> 7>  riakc_pb_socket:put(Pid, Object).
> {error,disconnected}
> 8>
> =ERROR REPORT==== 16-Mar-2011::22:19:42 ===
> ** Generic server <0.54.0> terminating
> ** Last message in was {tcp_closed,#Port<0.1105>}
> ** When Server state == {state,"127.0.0.1",8091,false,false,undefined,
>                                undefined,
>                                {[],[]},
>                                1,[],infinity,100}
> ** Reason for termination ==
> ** disconnected
> ** exception error: disconnected
> 8>
> =CRASH REPORT==== 16-Mar-2011::22:19:42 ===
>   crasher:
>     initial call: riakc_pb_socket:init/1
>     pid: <0.54.0>
>     registered_name: []
>     exception exit: disconnected
>       in function  gen_server:terminate/6
>     ancestors: [<0.32.0>]
>     messages: []
>     links: [<0.32.0>]
>     dictionary: []
>     trap_exit: false
>     status: running
>     heap_size: 610
>     stack_size: 24
>     reductions: 550
>   neighbours:
>     neighbour: [{pid,<0.32.0>},
>                   {registered_name,[]},
>                   {initial_call,{erlang,apply,2}},
>                   {current_function,{shell,eval_loop,3}},
>                   {ancestors,[]},
>                   {messages,[]},
>                   {links,[<0.27.0>,<0.54.0>]},
>                   {dictionary,[]},
>                   {trap_exit,false},
>                   {status,waiting},
>                   {heap_size,377},
>                   {stack_size,7},
>                   {reductions,13535}]
>
>
>
> Any thoughts ?
>
> I was able to obtain the Pid fine ->
>
> 5> {ok, Pid} = riakc_pb_socket:start_link("127.0.0.1", 8091).
>
> =PROGRESS REPORT==== 16-Mar-2011::22:19:20 ===
>           supervisor: {local,inet_gethost_native_sup}
>              started:
> [{pid,<0.56.0>},{mfa,{inet_gethost_native,init,[[]]}}]
>
> =PROGRESS REPORT==== 16-Mar-2011::22:19:20 ===
>           supervisor: {local,kernel_safe_sup}
>              started: [{pid,<0.55.0>},
>                        {name,inet_gethost_native_sup},
>                        {mfa,{inet_gethost_native,start_link,[]}},
>                        {restart_type,temporary},
>                        {shutdown,1000},
>                        {child_type,worker}]
> {ok,<0.54.0>}
>
>
> Thank you !
>
> Saurabh
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110316/1672612c/attachment.html>


More information about the riak-users mailing list