Java client API
wmacgyver at gmail.com
Thu Mar 24 02:07:01 EDT 2011
On Mar 23, 2011, at 2:25 PM, Jon Brisbin <jon at jbrisbin.com> wrote:
> I personally don't like using ambiguous short names. I get that you can technically distinguish things by package name but using a simple name that is very common isn't good for code readability. "RiakEntry" is unambiguous, self-documenting, and semantically correct. "Entry" would, in my mind, represent a very generic interface that defined various kinds of "Entry"s of things.
Likewise, I'd like to suggest RiakDoc
> This feels like a Grails GORM convention. Using finders and calling save directly on the object you're working with. I guess it's more a matter of personal preference, but I'm not sure I like it as a general rule. It's not a very object-oriented approach, either, as it mixes concerns a little too much, in my mind.
I like it actually, though not surprising. Since I am using grails with riak.
All my standalone scripts are written in groovy but make use of riak java client.
More information about the riak-users