Java client API

Russell Brown russell.brown at
Thu Mar 24 04:12:02 EDT 2011

On 24 Mar 2011, at 06:07, Wilson MacGyver wrote:

> On Mar 23, 2011, at 2:25 PM, Jon Brisbin <jon at> wrote:
>> I personally don't like using ambiguous short names. I get that you can technically distinguish things by package name but using a simple name that is very common isn't good for code readability. "RiakEntry" is unambiguous, self-documenting, and semantically correct. "Entry" would, in my mind, represent a very generic interface that defined various kinds of "Entry"s of things.
> Likewise, I'd like to suggest RiakDoc

I can see why but I think that might be too specific, not every entry in riak is a document (but every document in riak is an entry.)

> _______________________
> riak-users mailing list
> riak-users at

More information about the riak-users mailing list