Very, very slow data insert on two node cluster

Vlatko Basic vlatko.basic at gmail.com
Fri May 6 05:38:30 EDT 2011


Hi,

I've build a cluster with two physical Ubuntu 10.10 64-bit 4GB machines (laptop, 
2 cores, 2.4GHz and desktop, 4 cores, 3.1GHz) and I am trying to "load_data 
goog.csv" (around 1500 records) from a Fast Track tutorial. It took over 15 minutes.

Riak installation (both from DEB package) is correct and working. Other examples 
worked as shown.

1. Inserts are very, very slow. Maybe 1 insert in 2 secs??? Memory used around 
50%. Network is wired.
2. All inserts go to the local node that I'm working on, the other node is idle.

I attached status for both nodes and bucket properties.

Is it a bug, or have I made a bug? :-)

Thank for any ideas...


vlatko


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: bucket props
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110506/95ecf36b/attachment-0003.pl>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: status1
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110506/95ecf36b/attachment-0004.pl>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: status2
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110506/95ecf36b/attachment-0005.pl>


More information about the riak-users mailing list