Very, very slow data insert on two node cluster

Jeremiah Peschka jeremiah.peschka at gmail.com
Fri May 6 06:48:18 EDT 2011


One thing you'll want to do is adjust your nval if this is a development
cluster. With an nval of 3, one machine is always writing two copies of the
data. If this is for dev, you can get away with a single node cluster and an
nval of 1.

Jeremiah Peschka
Founder, Brent Ozar PLF
SQL MVP, MCITP: DBA, Database Developer


On Fri, May 6, 2011 at 5:48 AM, Vlatko Basic <vlatko.basic at gmail.com> wrote:

> Hi,
>
> I've build a cluster with two physical Ubuntu 10.10 64-bit 4GB machines
> (laptop, 2 cores, 2.4GHz and desktop, 4 cores, 3.1GHz) and I am trying to
> "load_data goog.csv" (around 1500 records) from a Fast Track tutorial. It
> took over 15 minutes.
>
> Riak installation (both from DEB package) is correct and working. Other
> examples worked as shown.
>
> 1. Inserts are very, very slow. Maybe 1 insert in 2 secs??? Memory used
> around 50%. Network is wired.
> 2. All inserts go to the local node that I'm working on, the other node is
> idle.
>
> I attached status for both nodes and bucket properties.
>
> Is it a bug, or have I made a bug? :-)
>
> Thank for any ideas...
>
>
> vlatko
>
> P.S.: Sorry if this email was sent twice.
>
>
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20110506/132d3c0b/attachment.html>


More information about the riak-users mailing list